What’s Vulnerable › Vulnerabilities
CVE-2019-5432
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-05-06 · updated 2026-06-17
- Weakness: CWE-126
Description
A specifically malformed MQTT Subscribe packet crashes MQTT Brokers using the mqtt-packet module versions < 3.5.1, 4.0.0 - 4.1.3, 5.0.0 - 5.6.1, 6.0.0 - 6.1.2 for decoding.
Affected products
- mqtt-packet: before 3.5.1; from 4.0.0 through 4.1.3; from 5.0.0 through 5.6.1; from 6.0.0 through 6.1.2 — fixed in 3.5.1
How to fix
Upgrade to a fixed version: mqtt-packet 3.5.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-5432 or the next vulnerability affects your stack