What’s Vulnerable › Vulnerabilities
CVE-2019-5439
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-06-13 · updated 2026-06-17
- Weakness: CWE-120
Description
A Buffer Overflow in VLC Media Player < 3.0.7 causes a crash which can possibly be further developed into a remote code execution exploit.
Affected products
- VideoLAN VLC: before 3.0.7 — fixed in 3.0.7
How to fix
Upgrade to a fixed version: VideoLAN VLC 3.0.7. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00005.html
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00037.html
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00040.html
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00081.html
- http://www.securityfocus.com/bid/108769
- https://hackerone.com/reports/484398
- https://security.gentoo.org/glsa/201908-23
- https://usn.ubuntu.com/4074-1/
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00005.html
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00037.html
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00040.html
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00081.html
Get alerted when CVE-2019-5439 or the next vulnerability affects your stack