What’s Vulnerable › Vulnerabilities
CVE-2019-5448
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-07-30 · updated 2026-06-17
- Weakness: CWE-311
Description
Yarn before 1.17.3 is vulnerable to Missing Encryption of Sensitive Data due to HTTP URLs in lockfile causing unencrypted authentication data to be sent over the network.
Affected products
- yarn: before 1.17.3 — fixed in 1.17.3
How to fix
Upgrade to a fixed version: yarn 1.17.3. Check the vendor advisory for mitigations.
References
- https://github.com/ChALkeR/notes/blob/master/Yarn-vuln.md
- https://hackerone.com/reports/640904
- https://yarnpkg.com/blog/2019/07/12/recommended-security-update/
- https://github.com/ChALkeR/notes/blob/master/Yarn-vuln.md
- https://hackerone.com/reports/640904
- https://yarnpkg.com/blog/2019/07/12/recommended-security-update/
Get alerted when CVE-2019-5448 or the next vulnerability affects your stack