What’s Vulnerable › Vulnerabilities
CVE-2019-5461
- Severity: low (CVSS 3.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-09-09 · updated 2026-06-17
- Weakness: CWE-20
Description
An input validation problem was discovered in the GitHub service integration which could result in an attacker being able to make arbitrary POST requests in a GitLab instance's internal network. This vulnerability was addressed in 12.1.2, 12.0.4, and 11.11.6.
Affected products
- GitLab: from 11.11.0 before 11.11.7; from 12.0.0 before 12.0.4; from 12.1.0 before 12.1.2 — fixed in 11.11.7, 12.0.4, 12.1.2
How to fix
Upgrade to a fixed version: GitLab 11.11.7, 12.0.4, 12.1.2. Check the vendor advisory for mitigations.
References
- https://gitlab.com//gitlab-org/gitlab-ce/issues/54649
- https://hackerone.com/reports/446593
- https://about.gitlab.com/2019/07/29/security-release-gitlab-12-dot-1-dot-2-released/
- https://gitlab.com//gitlab-org/gitlab-ce/issues/54649
- https://hackerone.com/reports/446593
Get alerted when CVE-2019-5461 or the next vulnerability affects your stack