What’s Vulnerable › Vulnerabilities
CVE-2019-5467
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-09-09 · updated 2026-06-17
- Weakness: CWE-79
Description
An input validation and output encoding issue was discovered in the GitLab CE/EE wiki pages feature which could result in a persistent XSS. This vulnerability was addressed in 12.1.2, 12.0.4, and 11.11.6.
Affected products
- GitLab: from 11.11.2 before 11.11.7; from 12.0.0 before 12.0.4; from 12.1.0 before 12.1.2 — fixed in 11.11.7, 12.0.4, 12.1.2
How to fix
Upgrade to a fixed version: GitLab 11.11.7, 12.0.4, 12.1.2. Check the vendor advisory for mitigations.
References
- https://gitlab.com/gitlab-org/gitlab-ce/issues/60143
- https://hackerone.com/reports/526325
- https://gitlab.com/gitlab-org/gitlab-ce/issues/60143
- https://hackerone.com/reports/526325
Get alerted when CVE-2019-5467 or the next vulnerability affects your stack