What’s Vulnerable › Vulnerabilities
CVE-2019-5487
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-12-18 · updated 2026-06-17
- Weakness: CWE-284
Description
An improper access control vulnerability exists in Gitlab EE <v12.3.3, <v12.2.7, & <v12.1.13 that allowed the group search feature with Elasticsearch to return private code, merge requests and commits.
Affected products
- GitLab: before 12.1.13; from 12.2.0 before 12.2.7; from 12.3.0 before 12.3.3 — fixed in 12.1.13, 12.2.7, 12.3.3
How to fix
Upgrade to a fixed version: GitLab 12.1.13, 12.2.7, 12.3.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-5487 or the next vulnerability affects your stack