What’s Vulnerable › Vulnerabilities
CVE-2019-5512
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-04-09 · updated 2026-06-17
Description
VMware Workstation (15.x before 15.0.3, 14.x before 14.1.6) running on Windows does not handle COM classes appropriately. Successful exploitation of this issue may allow hijacking of COM classes used by the VMX process, on a Windows host, leading to elevation of privilege.
Affected products
- VMware Workstation: from 14.0.0 before 14.1.6; from 15.0.0 before 15.0.3 — fixed in 14.1.6, 15.0.3
- VMware Workstation: from VMware Workstation 15.x prior through 15.0.3, 14.x before 14.1.6
How to fix
Upgrade to a fixed version: VMware Workstation 14.1.6, 15.0.3. Check the vendor advisory for mitigations.
References
- https://www.vmware.com/security/advisories/VMSA-2019-0002.html
- https://www.vmware.com/security/advisories/VMSA-2019-0002.html
Get alerted when CVE-2019-5512 or the next vulnerability affects your stack