What’s Vulnerable › Vulnerabilities
CVE-2019-5514
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-04-01 · updated 2026-06-17
- Weakness: CWE-306
Description
VMware VMware Fusion (11.x before 11.0.3) contains a security vulnerability due to certain unauthenticated APIs accessible through a web socket. An attacker may exploit this issue by tricking the host user to execute a JavaScript to perform unauthorized functions on the guest machine where VMware Tools is installed. This may further be exploited to execute commands on the guest machines.
Affected products
- VMware Fusion: from 11.0.0 before 11.0.3 — fixed in 11.0.3
- VMware Fusion: 11.x before 11.0.3
How to fix
Upgrade to a fixed version: VMware Fusion 11.0.3. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/152290/VMware-Security-Advisory-2019-0005.html
- http://www.securityfocus.com/bid/107637
- https://www.vmware.com/security/advisories/VMSA-2019-0005.html
- http://packetstormsecurity.com/files/152290/VMware-Security-Advisory-2019-0005.html
- http://www.securityfocus.com/bid/107637
- https://www.vmware.com/security/advisories/VMSA-2019-0005.html
Get alerted when CVE-2019-5514 or the next vulnerability affects your stack