What’s Vulnerable › Vulnerabilities
CVE-2019-5518
- Severity: medium (CVSS 6.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-04-01 · updated 2026-06-17
- Weakness: CWE-125
Description
VMware ESXi (6.7 before ESXi670-201903001, 6.5 before ESXi650-201903001, 6.0 before ESXi600-201903001), Workstation (15.x before 15.0.4, 14.x before 14.1.7), Fusion (11.x before 11.0.3, 10.x before 10.1.6) contain an out-of-bounds read/write vulnerability in the virtual USB 1.1 UHCI (Universal Host Controller Interface). Exploitation of this issue requires an attacker to have access to a virtual machine with a virtual USB controller present. This issue may allow a guest to execute code on the host.
Affected products
- VMware ESXi: 6.0-600-201811001, 6.0-600-201811401, 6.5-650-201707101, 6.5-650-201707102, 6.5-650-201707103, 6.5-650-201707201 (+62); 6.0, 6.5, 6.7
- VMware Fusion: from 10.0.0 before 10.1.6; from 11.0.0 before 11.0.3 — fixed in 10.1.6, 11.0.3
- VMware Workstation: from 14.0.0 before 14.1.7; from 15.0.0 before 15.0.4 — fixed in 14.1.7, 15.0.4
- VMware ESXi, Workstation, Fusion: ESXi 6.7 before ESXi670-201903001, ESXi 6.5 before ESXi650-201903001, ESXi 6.0 before ESXi600-201903001, Workstation 15.x before 15.0.4, Workstation 14.x before 14.1.7, Fusion 11.x before 11.0.3 (+1)
How to fix
Upgrade to a fixed version: VMware Fusion 10.1.6, 11.0.3; VMware Workstation 14.1.7, 15.0.4. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/152290/VMware-Security-Advisory-2019-0005.html
- http://www.securityfocus.com/bid/107541
- https://www.vmware.com/security/advisories/VMSA-2019-0005.html
- https://www.zerodayinitiative.com/advisories/ZDI-19-421/
- http://packetstormsecurity.com/files/152290/VMware-Security-Advisory-2019-0005.html
- http://www.securityfocus.com/bid/107541
- https://www.vmware.com/security/advisories/VMSA-2019-0005.html
- https://www.zerodayinitiative.com/advisories/ZDI-19-421/
Get alerted when CVE-2019-5518 or the next vulnerability affects your stack