What’s Vulnerable › Vulnerabilities
CVE-2019-5527
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-10-10 · updated 2026-06-17
- Weakness: CWE-416
Description
ESXi, Workstation, Fusion, VMRC and Horizon Client contain a use-after-free vulnerability in the virtual sound device. VMware has evaluated the severity of this issue to be in the Important severity range with a maximum CVSSv3 base score of 8.5.
Affected products
- VMware ESXi: 6.0-1, 6.0-1a, 6.0-1b, 6.0-2, 6.0-3, 6.0-3a (+170); 6.0, 6.5, 6.7
- VMware Fusion: from 11.0.0 before 11.5.0 — fixed in 11.5.0
- VMware Horizon Agent for Linux: before 5.2.0 — fixed in 5.2.0
- VMware Remote Console: from 10.0.0 before 10.0.5 — fixed in 10.0.5
- VMware Workstation: from 15.0.0 before 15.5.0 — fixed in 15.5.0
- ESXi, Workstation, Fusion, VMRC and Horizon Client: through ESXi 6.7. 6.5, 6.0, Workstation 15.x, Fusion 11.x, VMRC 10.x and Horizon Client 5.x
How to fix
Upgrade to a fixed version: VMware Fusion 11.5.0; VMware Horizon Agent for Linux 5.2.0; VMware Remote Console 10.0.5; VMware Workstation 15.5.0. Check the vendor advisory for mitigations.
References
- https://www.vmware.com/security/advisories/VMSA-2019-0014.html
- https://www.vmware.com/security/advisories/VMSA-2019-0014.html
Get alerted when CVE-2019-5527 or the next vulnerability affects your stack