What’s Vulnerable › Vulnerabilities
CVE-2019-5536
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-10-28 · updated 2026-06-17
Description
VMware ESXi (6.7 before ESXi670-201908101-SG and 6.5 before ESXi650-201910401-SG), Workstation (15.x before 15.5.0) and Fusion (11.x before 11.5.0) contain a denial-of-service vulnerability in the shader functionality. Successful exploitation of this issue may allow attackers with normal user privileges to create a denial-of-service condition on their own VM. Exploitation of this issue require an attacker to have access to a virtual machine with 3D graphics enabled. It is not enabled by default on ESXi and is enabled by default on Workstation and Fusion.
Affected products
- VMware ESXi: 6.5-650-201701001, 6.5-650-201703001, 6.5-650-201703002, 6.5-650-201704001, 6.5-650-201707101, 6.5-650-201707102 (+117); 6.5, 6.7
- VMware Fusion: from 11.0.0 before 11.5.0 — fixed in 11.5.0
- VMware Workstation: from 15.0.0 before 15.5.0 — fixed in 15.5.0
- VMware ESXi, Workstation and Fusion: VMware ESXi (6.7 before ESXi670-201908101-SG and 6.5 before ESXi650-201910401-SG), Workstation (15.x before 15.5.0) and Fusion (11.x before 11.5.0)
How to fix
Upgrade to a fixed version: VMware Fusion 11.5.0; VMware Workstation 15.5.0. Check the vendor advisory for mitigations.
References
- https://www.vmware.com/security/advisories/VMSA-2019-0019.html
- https://www.vmware.com/security/advisories/VMSA-2019-0019.html
Get alerted when CVE-2019-5536 or the next vulnerability affects your stack