What’s Vulnerable › Vulnerabilities
CVE-2019-5542
- Severity: high (CVSS 7.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-20 · updated 2026-06-17
Description
VMware Workstation (15.x before 15.5.1) and Fusion (11.x before 11.5.1) contain a denial-of-service vulnerability in the RPC handler. Successful exploitation of this issue may allow attackers with normal user privileges to create a denial-of-service condition on their own VM.
Affected products
- VMware Fusion: from 11.0.0 before 11.5.1 — fixed in 11.5.1
- VMware Workstation: from 15.0.0 before 15.5.1 — fixed in 15.5.1
- VMware Workstation and Fusion: Workstation (15.x before 15.5.1) and Fusion (11.x before 11.5.1)
How to fix
Upgrade to a fixed version: VMware Fusion 11.5.1; VMware Workstation 15.5.1. Check the vendor advisory for mitigations.
References
- https://www.vmware.com/security/advisories/VMSA-2019-0021.html
- https://www.vmware.com/security/advisories/VMSA-2019-0021.html
Get alerted when CVE-2019-5542 or the next vulnerability affects your stack