What’s Vulnerable › Vulnerabilities
CVE-2019-5642: MAGICK
- Severity: low (CVSS 3.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-06 · updated 2026-06-17
- Weakness: CWE-732
Description
Rapid7 Metasploit Pro version 4.16.0-2019081901 and prior suffers from an instance of CWE-732, wherein the unique server.key is written to the file system during installation with world-readable permissions. This can allow other users of the same system where Metasploit Pro is installed to intercept otherwise private communications to the Metasploit Pro web interface.
Affected products
- Rapid7 Metasploit Framework: before 4.16.0; 4.16.0, 4.16.0-20190722, 4.16.0-20190805, 4.16.0-2019081901 — fixed in 4.16.0
How to fix
Upgrade to a fixed version: Rapid7 Metasploit Framework 4.16.0. Check the vendor advisory for mitigations.
References
- https://help.rapid7.com/metasploit/release-notes/?rid=4.16.0-2019091001
- https://help.rapid7.com/metasploit/release-notes/?rid=4.16.0-2019091001
Get alerted when CVE-2019-5642 or the next vulnerability affects your stack