What’s Vulnerable › Vulnerabilities
CVE-2019-5647: Rapid7 AppSpider Chrome Plugin Insufficient Session Expiration
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-22 · updated 2026-06-17
- Weakness: CWE-613
Description
The Chrome Plugin for Rapid7 AppSpider can incorrectly keep browser sessions active after recording a macro, even after a restart of the Chrome browser. This behavior could make future session hijacking attempts easier, since the user could believe a session was closed when it was not. This issue affects Rapid7 AppSpider version 3.8.213 and prior versions, and is fixed in version 3.8.215.
Affected products
- Rapid7 AppSpider: through 3.8.213
References
- https://help.rapid7.com/appspiderenterprise/release-notes/?rid=3.8.215
- https://help.rapid7.com/appspiderenterprise/release-notes/?rid=3.8.215
Get alerted when CVE-2019-5647 or the next vulnerability affects your stack