What’s Vulnerable › Vulnerabilities
CVE-2019-5729
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-21 · updated 2026-06-17
- Weakness: CWE-295
Description
Splunk-SDK-Python before 1.6.6 does not properly verify untrusted TLS server certificates, which could result in man-in-the-middle attacks.
Affected products
- Splunk Software Development Kit: before 1.6.6 — fixed in 1.6.6
How to fix
Upgrade to a fixed version: Splunk Software Development Kit 1.6.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-5729 or the next vulnerability affects your stack