What’s Vulnerable › Vulnerabilities

CVE-2019-5737

Description

In Node.js including 6.x before 6.17.0, 8.x before 8.15.1, 10.x before 10.15.2, and 11.x before 11.10.1, an attacker can cause a Denial of Service (DoS) by establishing an HTTP or HTTPS connection in keep-alive mode and by sending headers very slowly. This keeps the connection and associated resources alive for a long period of time. Potential attacks are mitigated by the use of a load balancer or other proxy layer. This vulnerability is an extension of CVE-2018-12121, addressed in November and impacts all active Node.js release lines including 6.x before 6.17.0, 8.x before 8.15.1, 10.x before 10.15.2, and 11.x before 11.10.1.

Affected products

How to fix

Upgrade to a fixed version: Node.js 10.15.2, 11.10.1, 6.17.0, 8.15.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-5737 or the next vulnerability affects your stack