What’s Vulnerable › Vulnerabilities
CVE-2019-5815: Nokogiri implementation of libxslt vulnerable to heap corruption
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-12-11 · updated 2026-06-17
- Weakness: CWE-787
Description
Type confusion in xsltNumberFormatGetMultipleLevel prior to libxslt 1.1.33 could allow attackers to potentially exploit heap corruption via crafted XML data.
Affected products
- Debian Linux: 10.0
- xmlsoft libxslt: before 1.1.33 — fixed in 1.1.33
- Rubygems Nokogiri: before 1.10.5; 1.0.0, 1.0.1, 1.0.2, 1.0.3, 1.0.4, 1.0.5 (+108) — fixed in 1.10.5
How to fix
Upgrade to a fixed version: xmlsoft libxslt 1.1.33; Rubygems Nokogiri 1.10.5. Check the vendor advisory for mitigations.
References
- https://bugs.chromium.org/p/chromium/issues/detail?id=930663
- https://gitlab.gnome.org/GNOME/libxslt/commit/08b62c25871b38d5d573515ca8a065b4b8f64f6b
- https://lists.debian.org/debian-lts-announce/2022/09/msg00010.html
- https://bugs.chromium.org/p/chromium/issues/detail?id=930663
- https://gitlab.gnome.org/GNOME/libxslt/commit/08b62c25871b38d5d573515ca8a065b4b8f64f6b
- https://lists.debian.org/debian-lts-announce/2022/09/msg00010.html
Get alerted when CVE-2019-5815 or the next vulnerability affects your stack