What’s Vulnerable › Vulnerabilities
CVE-2019-5882
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-01-09 · updated 2026-06-17
- Weakness: CWE-416
Description
Irssi 1.1.x before 1.1.2 has a use after free when hidden lines are expired from the scroll buffer.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 18.10
- Irssi: from 1.1.0 before 1.1.2 — fixed in 1.1.2
How to fix
Upgrade to a fixed version: Irssi 1.1.2. Check the vendor advisory for mitigations.
References
- https://github.com/irssi/irssi/pull/948
- https://irssi.org/NEWS/#v1-1-2
- https://irssi.org/security/irssi_sa_2019_01.txt
- https://usn.ubuntu.com/3862-1/
- https://github.com/irssi/irssi/pull/948
- https://irssi.org/NEWS/#v1-1-2
- https://irssi.org/security/irssi_sa_2019_01.txt
- https://usn.ubuntu.com/3862-1/
Get alerted when CVE-2019-5882 or the next vulnerability affects your stack