What’s Vulnerable › Vulnerabilities
CVE-2019-6010
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-09-19 · updated 2026-06-17
- Weakness: CWE-190
Description
Integer overflow vulnerability in LINE(Android) from 4.4.0 to the version before 9.15.1 allows remote attackers to cause a denial of service (DoS) condition or execute arbitrary code via a specially crafted image.
Affected products
- LINE Corporation LINE client for iOS: from 4.4.0 before 9.15.1 — fixed in 9.15.1
How to fix
Upgrade to a fixed version: LINE Corporation LINE client for iOS 9.15.1. Check the vendor advisory for mitigations.
References
- http://jvn.jp/en/jp/JVN97845465/index.html
- https://play.google.com/store/apps/details?id=jp.naver.line.android&hl=en
- http://jvn.jp/en/jp/JVN97845465/index.html
- https://play.google.com/store/apps/details?id=jp.naver.line.android&hl=en
Get alerted when CVE-2019-6010 or the next vulnerability affects your stack