What’s Vulnerable › Vulnerabilities
CVE-2019-6139
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-02-07 · updated 2026-06-17
- Weakness: CWE-434
Description
Forcepoint User ID (FUID) server versions up to 1.2 have a remote arbitrary file upload vulnerability on TCP port 5001. Successful exploitation of this vulnerability may lead to remote code execution. To fix this vulnerability, upgrade to FUID version 1.3 or higher. To prevent the vulnerability on FUID versions 1.2 and below, apply local firewall rules on the FUID server to disable all external access to port TCP/5001. FUID requires this port only for local connections through the loopback interface.
Affected products
- Forcepoint . Forcepoint User ID (FUID) server: before 1.3.0 — fixed in 1.3.0
How to fix
Upgrade to a fixed version: Forcepoint . Forcepoint User ID (FUID) server 1.3.0. Check the vendor advisory for mitigations.
References
- https://help.forcepoint.com/security/CVE/CVE-2019-6139.html
- https://help.forcepoint.com/security/CVE/CVE-2019-6139.html
Get alerted when CVE-2019-6139 or the next vulnerability affects your stack