What’s Vulnerable › Vulnerabilities
CVE-2019-6146
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-01-22 · updated 2026-06-17
- Weakness: CWE-79
Description
It has been reported that cross-site scripting (XSS) is possible in Forcepoint Web Security, version 8.x, via host header injection. CVSSv3.0: 5.3 (Medium) (/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N)
Affected products
- Forcepoint Web Security: from 8.0.0 before 8.5.4 — fixed in 8.5.4
How to fix
Upgrade to a fixed version: Forcepoint Web Security 8.5.4. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/156274/Forcepoint-WebSecurity-8.5-Cross-Site-Scripting.html
- https://help.forcepoint.com/security/CVE/CVE-2019-6146.html
- http://packetstormsecurity.com/files/156274/Forcepoint-WebSecurity-8.5-Cross-Site-Scripting.html
- https://help.forcepoint.com/security/CVE/CVE-2019-6146.html
Get alerted when CVE-2019-6146 or the next vulnerability affects your stack