What’s Vulnerable › Vulnerabilities
CVE-2019-6179
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-09-03 · updated 2026-06-17
- Weakness: CWE-611
Description
An XML External Entity (XXE) processing vulnerability was reported in Lenovo XClarity Administrator (LXCA) prior to version 2.5.0 , Lenovo XClarity Integrator (LXCI) for Microsoft System Center prior to version 7.7.0, and Lenovo XClarity Integrator (LXCI) for VMWare vCenter prior to version 6.1.0 that could allow information disclosure.
Affected products
- Lenovo XClarity Administrator: before 2.5.0 — fixed in 2.5.0
- Lenovo Xclarity Integrator: before 6.1.0; before 7.7.0 — fixed in 6.1.0, 7.7.0
How to fix
Upgrade to a fixed version: Lenovo XClarity Administrator 2.5.0; Lenovo Xclarity Integrator 6.1.0, 7.7.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-6179 or the next vulnerability affects your stack