What’s Vulnerable › Vulnerabilities
CVE-2019-6250
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 9.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-01-13 · updated 2026-06-17
- Weakness: CWE-190
Description
A pointer overflow, with code execution, was discovered in ZeroMQ libzmq (aka 0MQ) 4.2.x and 4.3.x before 4.3.1. A v2_decoder.cpp zmq::v2_decoder_t::size_ready integer overflow allows an authenticated attacker to overwrite an arbitrary amount of bytes beyond the bounds of a buffer, which can be leveraged to run arbitrary code on the target system. The memory layout allows the attacker to inject OS commands into a data structure located immediately after the problematic buffer (i.e., it is not necessary to use a typical buffer-overflow exploitation technique that changes the flow of control).
Affected products
- Debian Linux: 9.0
- zeromq libzmq: from 4.2.0 through 4.2.5; from 4.3.0 before 4.3.1 — fixed in 4.3.1
How to fix
Upgrade to a fixed version: zeromq libzmq 4.3.1. Check the vendor advisory for mitigations.
References
- https://github.com/zeromq/libzmq/issues/3351
- https://github.com/zeromq/libzmq/releases/tag/v4.3.1
- https://security.gentoo.org/glsa/201903-22
- https://www.debian.org/security/2019/dsa-4368
- https://github.com/zeromq/libzmq/issues/3351
- https://github.com/zeromq/libzmq/releases/tag/v4.3.1
- https://security.gentoo.org/glsa/201903-22
- https://www.debian.org/security/2019/dsa-4368
Get alerted when CVE-2019-6250 or the next vulnerability affects your stack