What’s Vulnerable › Vulnerabilities
CVE-2019-6251
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-01-14 · updated 2026-06-17
Description
WebKitGTK and WPE WebKit prior to version 2.24.1 are vulnerable to address bar spoofing upon certain JavaScript redirections. An attacker could cause malicious web content to be displayed as if for a trusted URI. This is similar to the CVE-2018-8383 issue in Microsoft Edge.
Affected products
- Canonical Ubuntu Linux: 18.04, 18.10
- Fedoraproject Fedora: 28, 29, 30
- GNOME Epiphany: through 3.31.4
- openSUSE Leap: 15.0, 42.3
- Webkit: before 2.24.1 — fixed in 2.24.1
- Wpewebkit Wpe Webkit: before 2.24.1 — fixed in 2.24.1
How to fix
Upgrade to a fixed version: Webkit 2.24.1; Wpewebkit Wpe Webkit 2.24.1. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00025.html
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00031.html
- http://packetstormsecurity.com/files/152485/WebKitGTK-WPE-WebKit-URI-Spoofing-Code-Execution.html
- http://www.openwall.com/lists/oss-security/2019/04/11/1
- https://bugs.webkit.org/show_bug.cgi?id=194208
- https://gitlab.gnome.org/GNOME/epiphany/issues/532
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/HSCDI3635E37GL4BNJDRDT2KEUBDLGSO/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/LACVFU4MYYRPJ3IEA4UCN5KUEAGCCJ72/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/TNPI3R6QWDJBA5KNGA6QSMKYLY5RRHBZ/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UO3DIA54X7FOUWFZW5YXC2MZ6KNHG6SW/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/YO5ZBUWOOXMVZPBYLZRDZF6ZQGBYJERQ/
- https://seclists.org/bugtraq/2019/Apr/21
Get alerted when CVE-2019-6251 or the next vulnerability affects your stack