What’s Vulnerable › Vulnerabilities
CVE-2019-6339: PHAR stream wrapper Arbitrary PHP code execution
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 35.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-01-22 · updated 2026-06-17
- Weakness: CWE-20
Description
In Drupal Core versions 7.x prior to 7.62, 8.6.x prior to 8.6.6 and 8.5.x prior to 8.5.9; A remote code execution vulnerability exists in PHP's built-in phar stream wrapper when performing file operations on an untrusted phar:// URI. Some Drupal code (core, contrib, and custom) may be performing file operations on insufficiently validated user input, thereby being exposed to this vulnerability. This vulnerability is mitigated by the fact that such code paths typically require access to an administrative permission or an atypical configuration.
Affected products
- Debian Linux: 8.0, 9.0
- Drupal: from 7.0 before 7.62; from 8.5.0 before 8.5.9; from 8.6.0 before 8.6.6 — fixed in 7.62, 8.5.9, 8.6.6
How to fix
Upgrade to a fixed version: Drupal 7.62, 8.5.9, 8.6.6. Check the vendor advisory for mitigations.
References
- https://lists.debian.org/debian-lts-announce/2019/02/msg00004.html
- https://www.debian.org/security/2019/dsa-4370
- https://www.drupal.org/sa-core-2019-002
- https://lists.debian.org/debian-lts-announce/2019/02/msg00004.html
- https://www.debian.org/security/2019/dsa-4370
- https://www.drupal.org/sa-core-2019-002
Get alerted when CVE-2019-6339 or the next vulnerability affects your stack