What’s Vulnerable › Vulnerabilities

CVE-2019-6340: Drupal Core Remote Code Execution Vulnerability

Description

Some field types do not properly sanitize data from non-form sources in Drupal 8.5.x before 8.5.11 and Drupal 8.6.x before 8.6.10. This can lead to arbitrary PHP code execution in some cases. A site is only affected by this if one of the following conditions is met: The site has the Drupal 8 core RESTful Web Services (rest) module enabled and allows PATCH or POST requests, or the site has another web services module enabled, like JSON:API in Drupal 8, or Services or RESTful Web Services in Drupal 7. (Note: The Drupal 7 Services module itself does not require an update at this time, but you should apply other contributed updates associated with this advisory if Services is in use.)

Affected products

How to fix

Upgrade to a fixed version: Drupal 8.5.11, 8.6.10. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-6340 or the next vulnerability affects your stack