What’s Vulnerable › Vulnerabilities
CVE-2019-6442
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 13.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-01-16 · updated 2026-06-17
- Weakness: CWE-787
Description
An issue was discovered in NTPsec before 1.1.3. An authenticated attacker can write one byte out of bounds in ntpd via a malformed config request, related to config_remotely in ntp_config.c, yyparse in ntp_parser.tab.c, and yyerror in ntp_parser.y.
Affected products
- ntpsec: before 1.1.3 — fixed in 1.1.3
How to fix
Upgrade to a fixed version: ntpsec 1.1.3. Check the vendor advisory for mitigations.
References
- https://dumpco.re/blog/ntpsec-bugs
- https://dumpco.re/bugs/ntpsec-authed-oobwrite
- https://github.com/ntpsec/ntpsec/blob/NTPsec_1_1_3/NEWS
- https://www.exploit-db.com/exploits/46178/
- https://dumpco.re/blog/ntpsec-bugs
- https://dumpco.re/bugs/ntpsec-authed-oobwrite
- https://github.com/ntpsec/ntpsec/blob/NTPsec_1_1_3/NEWS
- https://www.exploit-db.com/exploits/46178/
Get alerted when CVE-2019-6442 or the next vulnerability affects your stack