What’s Vulnerable › Vulnerabilities
CVE-2019-6443
- Severity: critical (CVSS 9.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 66.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-01-16 · updated 2026-06-17
- Weakness: CWE-125
Description
An issue was discovered in NTPsec before 1.1.3. Because of a bug in ctl_getitem, there is a stack-based buffer over-read in read_sysvars in ntp_control.c in ntpd.
Affected products
- ntpsec: before 1.1.3 — fixed in 1.1.3
How to fix
Upgrade to a fixed version: ntpsec 1.1.3. Check the vendor advisory for mitigations.
References
- https://dumpco.re/blog/ntpsec-bugs
- https://dumpco.re/bugs/ntpsec-oobread1
- https://github.com/ntpsec/ntpsec/blob/NTPsec_1_1_3/NEWS
- https://www.exploit-db.com/exploits/46175/
- https://dumpco.re/blog/ntpsec-bugs
- https://dumpco.re/bugs/ntpsec-oobread1
- https://github.com/ntpsec/ntpsec/blob/NTPsec_1_1_3/NEWS
- https://www.exploit-db.com/exploits/46175/
Get alerted when CVE-2019-6443 or the next vulnerability affects your stack