What’s Vulnerable › Vulnerabilities

CVE-2019-6486

Description

Go before 1.10.8 and 1.11.x before 1.11.5 mishandles P-521 and P-384 elliptic curves, which allows attackers to cause a denial of service (CPU consumption) or possibly conduct ECDH private key recovery attacks.

Affected products

How to fix

Upgrade to a fixed version: Go 1.10.8, 1.11.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2019-6486 or the next vulnerability affects your stack