What’s Vulnerable › Vulnerabilities
CVE-2019-6528
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-05 · updated 2026-06-17
- Weakness: CWE-79
Description
PSI GridConnect GmbH Telecontrol Gateway and Smart Telecontrol Unit family, IEC104 Security Proxy versions Telecontrol Gateway 3G Versions 4.2.21, 5.0.27, 5.1.19, 6.0.16 and prior, and Telecontrol Gateway XS-MU Versions 4.2.21, 5.0.27, 5.1.19, 6.0.16 and prior, and Telecontrol Gateway VM Versions 4.2.21, 5.0.27, 5.1.19, 6.0.16 and prior, and Smart Telecontrol Unit TCG Versions 5.0.27, 5.1.19, 6.0.16 and prior, and IEC104 Security Proxy Version 2.2.10 and prior The web application browser interprets input as active HTML, JavaScript, or VBScript, which could allow an attacker to execute arbitrary code.
Affected products
- Psigridconnect Iec104 Security Proxy Firmware: through 2.2.10
- Psigridconnect Smart Telecontrol Unit Tcg Firmware: before 5.1.20; from 5.1.21 before 6.0.16 — fixed in 5.1.20, 6.0.16
- Psigridconnect Telecontrol Gateway 3G Firmware: before 5.1.20; from 5.1.21 before 6.0.16 — fixed in 5.1.20, 6.0.16
- Psigridconnect Telecontrol Gateway Vm Firmware: before 5.1.20; from 5.1.21 through 6.0.16 — fixed in 5.1.20
- Psigridconnect Telecontrol Gateway Xs-Mu Firmware: before 5.1.20; from 5.1.21 through 6.0.16 — fixed in 5.1.20
How to fix
Upgrade to a fixed version: Psigridconnect Smart Telecontrol Unit Tcg Firmware 5.1.20, 6.0.16; Psigridconnect Telecontrol Gateway 3G Firmware 5.1.20, 6.0.16; Psigridconnect Telecontrol Gateway Vm Firmware 5.1.20; Psigridconnect Telecontrol Gateway Xs-Mu Firmware 5.1.20. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/107201
- https://ics-cert.us-cert.gov/advisories/ICSA-19-059-01
- http://www.securityfocus.com/bid/107201
- https://ics-cert.us-cert.gov/advisories/ICSA-19-059-01
Get alerted when CVE-2019-6528 or the next vulnerability affects your stack