What’s Vulnerable › Vulnerabilities
CVE-2019-6555
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-02-28 · updated 2026-06-17
- Weakness: CWE-20
Description
Cscape, 9.80 SP4 and prior. An improper input validation vulnerability may be exploited by processing specially crafted POC files. This may allow an attacker to read confidential information and remotely execute arbitrary code.
Affected products
- Horner Automation Cscape: before 9.80; 9.80, 9.80-sp1, 9.80-sp2, 9.80-sp3, 9.80-sp4 — fixed in 9.80
How to fix
Upgrade to a fixed version: Horner Automation Cscape 9.80. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/107087
- https://ics-cert.us-cert.gov/advisories/ICSA-19-050-03
- http://www.securityfocus.com/bid/107087
- https://ics-cert.us-cert.gov/advisories/ICSA-19-050-03
Get alerted when CVE-2019-6555 or the next vulnerability affects your stack