What’s Vulnerable › Vulnerabilities
CVE-2019-6585
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-03-10 · updated 2026-06-17
- Weakness: CWE-80
Description
A vulnerability has been identified in SCALANCE S602 (All versions >= V3.0 and < V4.1), SCALANCE S612 (All versions >= V3.0 and < V4.1), SCALANCE S623 (All versions >= V3.0 and < V4.1), SCALANCE S627-2M (All versions >= V3.0 and < V4.1). The integrated configuration web server of the affected devices could allow Cross-Site Scripting (XSS) attacks if unsuspecting users are tricked into accessing a malicious link. User interaction is required for a successful exploitation. The user must be logged into the web interface in order for the exploitation to succeed.
Affected products
- Siemens Scalance S602 Firmware: from 3.0 before 4.1 — fixed in 4.1
- Siemens Scalance S612 Firmware: from 3.0 before 4.1 — fixed in 4.1
- Siemens Scalance S623 Firmware: from 3.0 before 4.1 — fixed in 4.1
- Siemens Scalance S627-2M Firmware: from 3.0 before 4.1 — fixed in 4.1
How to fix
Upgrade to a fixed version: Siemens Scalance S602 Firmware 4.1; Siemens Scalance S612 Firmware 4.1; Siemens Scalance S623 Firmware 4.1; Siemens Scalance S627-2M Firmware 4.1. Check the vendor advisory for mitigations.
References
- https://cert-portal.siemens.com/productcert/pdf/ssa-591405.pdf
- https://www.us-cert.gov/ics/advisories/icsa-20-042-10
- https://cert-portal.siemens.com/productcert/pdf/ssa-591405.pdf
- https://www.us-cert.gov/ics/advisories/icsa-20-042-10
Get alerted when CVE-2019-6585 or the next vulnerability affects your stack