What’s Vulnerable › Vulnerabilities
CVE-2019-6639
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-03 · updated 2026-06-17
- Weakness: CWE-79
Description
On BIG-IP (AFM, PEM) 14.1.0-14.1.0.5, 14.0.0-14.0.0.4, 13.0.0-13.1.1.4, 12.1.0-12.1.4, 11.6.1-11.6.3.4, and 11.5.1-11.5.8, an undisclosed TMUI pages for AFM and PEM Subscriber management are vulnerable to a stored cross-site scripting (XSS) issue. This is a control plane issue only and is not accessible from the data plane. The attack requires a malicious resource administrator to store the XSS.
Affected products
- BIG-IP: from 11.5.0 before 11.5.9; from 11.6.0 before 11.6.4; from 12.1.0 before 12.1.4.1; from 13.0.0 before 13.1.1.5; from 14.0.0 before 14.0.0.5; from 14.1.0 before 14.1.0.6 — fixed in 11.5.9, 11.6.4, 12.1.4.1, 13.1.1.5, 14.0.0.5, 14.1.0.6
- F5 Networks, Inc. BIG-IP (PEM): from 11.5.0 before 11.5.9; from 11.6.0 before 11.6.4; from 12.1.0 before 12.1.4.1; from 13.0.0 before 13.1.1.5; from 14.0.0 before 14.0.0.5; from 14.1.0 before 14.1.0.6 — fixed in 11.5.9, 11.6.4, 12.1.4.1, 13.1.1.5, 14.0.0.5, 14.1.0.6
How to fix
Upgrade to a fixed version: BIG-IP 11.5.9, 11.6.4, 12.1.4.1, 13.1.1.5; F5 Networks, Inc. BIG-IP (PEM) 11.5.9, 11.6.4, 12.1.4.1, 13.1.1.5. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/109064
- https://support.f5.com/csp/article/K61002104
- http://www.securityfocus.com/bid/109064
- https://support.f5.com/csp/article/K61002104
Get alerted when CVE-2019-6639 or the next vulnerability affects your stack