What’s Vulnerable › Vulnerabilities
CVE-2019-6661
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-11-15 · updated 2026-06-17
- Weakness: CWE-400
Description
When the BIG-IP APM 14.1.0-14.1.2, 14.0.0-14.0.1, 13.1.0-13.1.3.1, 12.1.0-12.1.4.1, or 11.5.1-11.6.5 system processes certain requests, the APD/APMD daemon may consume excessive resources.
Affected products
- F5 BIG-IP APM: from 11.6.2 before 11.6.5.1; from 12.1.0 before 12.1.5; from 13.0.0 before 13.1.3.2; from 14.0.0 before 14.0.1.1; from 14.1.0 before 14.1.2.1 — fixed in 11.6.5.1, 12.1.5, 13.1.3.2, 14.0.1.1, 14.1.2.1
How to fix
Upgrade to a fixed version: F5 BIG-IP APM 11.6.5.1, 12.1.5, 13.1.3.2, 14.0.1.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-6661 or the next vulnerability affects your stack