What’s Vulnerable › Vulnerabilities
CVE-2019-6687
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-12-23 · updated 2026-06-17
- Weakness: CWE-295
Description
On versions 15.0.0-15.0.1.1, the BIG-IP ASM Cloud Security Services profile uses a built-in verification mechanism that fails to properly authenticate the X.509 certificate of remote endpoints.
Affected products
- BIG-IP ASM: from 15.0.0 before 15.1.0 — fixed in 15.1.0
How to fix
Upgrade to a fixed version: BIG-IP ASM 15.1.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2019-6687 or the next vulnerability affects your stack