What’s Vulnerable › Vulnerabilities
CVE-2019-6742
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-06-03 · updated 2026-06-17
- Weakness: CWE-358
Description
This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Samsung Galaxy S9 prior to 1.4.20.2. Authentication is not required to exploit this vulnerability. The specific flaw exists within the handling of the GameServiceReceiver update mechanism. An attacker can leverage this vulnerability to execute code in the context of the current process. Was ZDI-CAN-7477.
Affected products
- Samsung Galaxy S9: before 1.4.20.2 — fixed in 1.4.20.2
How to fix
Upgrade to a fixed version: Samsung Galaxy S9 1.4.20.2. Check the vendor advisory for mitigations.
References
- https://www.zerodayinitiative.com/advisories/ZDI-19-255/
- https://www.zerodayinitiative.com/advisories/ZDI-19-255/
Get alerted when CVE-2019-6742 or the next vulnerability affects your stack