What’s Vulnerable › Vulnerabilities
CVE-2019-6781
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-05-17 · updated 2026-06-17
- Weakness: CWE-601
Description
An Improper Input Validation issue was discovered in GitLab Community and Enterprise Edition before 11.5.8, 11.6.x before 11.6.6, and 11.7.x before 11.7.1. It was possible to use the profile name to inject a potentially malicious link into notification emails.
Affected products
- GitLab: from 11.5.0 before 11.5.10; from 11.6.0 before 11.6.8; from 11.7.0 before 11.7.3 — fixed in 11.5.10, 11.6.8, 11.7.3
How to fix
Upgrade to a fixed version: GitLab 11.5.10, 11.6.8, 11.7.3. Check the vendor advisory for mitigations.
References
- https://about.gitlab.com/2019/01/31/security-release-gitlab-11-dot-7-dot-3-released/
- https://gitlab.com/gitlab-org/gitlab-ce/issues/22076
- https://about.gitlab.com/2019/01/31/security-release-gitlab-11-dot-7-dot-3-released/
- https://gitlab.com/gitlab-org/gitlab-ce/issues/22076
Get alerted when CVE-2019-6781 or the next vulnerability affects your stack