What’s Vulnerable › Vulnerabilities
CVE-2019-6785
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-09-09 · updated 2026-06-17
Description
An issue was discovered in GitLab Community and Enterprise Edition before 11.5.8, 11.6.x before 11.6.6, and 11.7.x before 11.7.1. It allows Denial of Service. Inputting an overly long string into a Markdown field could cause a denial of service.
Affected products
- GitLab: from 7.4.0 before 11.5.8; from 11.6.0 before 11.6.6; from 11.7.0 before 11.7.1 — fixed in 11.5.8, 11.6.6, 11.7.1
How to fix
Upgrade to a fixed version: GitLab 11.5.8, 11.6.6, 11.7.1. Check the vendor advisory for mitigations.
References
- https://about.gitlab.com/2019/01/31/security-release-gitlab-11-dot-7-dot-3-released/
- https://gitlab.com/gitlab-org/gitlab-ce/issues/52212
- https://about.gitlab.com/2019/01/31/security-release-gitlab-11-dot-7-dot-3-released/
- https://gitlab.com/gitlab-org/gitlab-ce/issues/52212
Get alerted when CVE-2019-6785 or the next vulnerability affects your stack