What’s Vulnerable › Vulnerabilities
CVE-2019-6956
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-01-25 · updated 2026-06-17
- Weakness: CWE-125
Description
An issue was discovered in Freeware Advanced Audio Decoder 2 (FAAD2) 2.8.8. It is a buffer over-read in ps_mix_phase in libfaad/ps_dec.c.
Affected products
- Audiocoding Freeware Advanced Audio Decoder 2: before 2.9.0 — fixed in 2.9.0
- Debian Linux: 8.0, 9.0, 10.0
How to fix
Upgrade to a fixed version: Audiocoding Freeware Advanced Audio Decoder 2 2.9.0. Check the vendor advisory for mitigations.
References
- https://github.com/TeamSeri0us/pocs/blob/master/faad/global-buffer-overflow%40ps_mix_phase.md
- https://lists.debian.org/debian-lts-announce/2019/08/msg00033.html
- https://lists.debian.org/debian-lts-announce/2021/10/msg00020.html
- https://security.gentoo.org/glsa/202006-17
- https://sourceforge.net/p/faac/bugs/240/
- https://www.debian.org/security/2022/dsa-5109
- https://github.com/TeamSeri0us/pocs/blob/master/faad/global-buffer-overflow%40ps_mix_phase.md
- https://lists.debian.org/debian-lts-announce/2019/08/msg00033.html
- https://lists.debian.org/debian-lts-announce/2021/10/msg00020.html
- https://security.gentoo.org/glsa/202006-17
- https://sourceforge.net/p/faac/bugs/240/
- https://www.debian.org/security/2022/dsa-5109
Get alerted when CVE-2019-6956 or the next vulnerability affects your stack