What’s Vulnerable › Vulnerabilities
CVE-2019-6970
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-21 · updated 2026-06-17
- Weakness: CWE-918
Description
Moodle 3.5.x before 3.5.4 allows SSRF.
Affected products
- Moodle: from 3.5.0 before 3.5.4 — fixed in 3.5.4
How to fix
Upgrade to a fixed version: Moodle 3.5.4. Check the vendor advisory for mitigations.
References
- https://cds.thalesgroup.com/en/tcs-cert/CVE-2019-6970
- https://www.excellium-services.com/cert-xlm-advisory
- https://www.excellium-services.com/cert-xlm-advisory/cve-2019-6970/
- https://www.excellium-services.com/cert-xlm-advisory/cve-2019-6970/
Get alerted when CVE-2019-6970 or the next vulnerability affects your stack