What’s Vulnerable › Vulnerabilities
CVE-2019-6985
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-01-28 · updated 2026-06-17
- Weakness: CWE-125
Description
An issue was discovered in Foxit 3D Plugin Beta before 9.4.0.16807 for Foxit Reader and PhantomPDF. The application could encounter an Out-of-Bounds Read in Indexing or a Heap Overflow and crash during handling of certain PDF files that embed specifically crafted 3D content, due to an array access violation.
Affected products
- Foxitsoftware 3D: before 9.4.0.16807 — fixed in 9.4.0.16807
How to fix
Upgrade to a fixed version: Foxitsoftware 3D 9.4.0.16807. Check the vendor advisory for mitigations.
References
- https://www.foxitsoftware.com/support/security-bulletins.php
- https://www.foxitsoftware.com/support/security-bulletins.php
Get alerted when CVE-2019-6985 or the next vulnerability affects your stack