What’s Vulnerable › Vulnerabilities
CVE-2019-7019
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-05-24 · updated 2026-06-17
- Weakness: CWE-787
Description
Adobe Acrobat and Reader versions 2019.010.20069 and earlier, 2019.010.20069 and earlier, 2017.011.30113 and earlier version, and 2015.006.30464 and earlier have an out-of-bounds write vulnerability. Successful exploitation could lead to arbitrary code execution .
Affected products
- Adobe Acrobat DC: from 15.006.30060 before 15.006.30475; from 15.008.20082 before 19.010.20091; from 17.011.30056 before 17.011.30120 — fixed in 15.006.30475, 17.011.30120, 19.010.20091
- Adobe Acrobat Reader: from 15.006.30060 before 15.006.30475; from 15.008.20082 before 19.010.20091; from 17.011.30059 before 17.011.30120 — fixed in 15.006.30475, 17.011.30120, 19.010.20091
How to fix
Upgrade to a fixed version: Adobe Acrobat DC 15.006.30475, 17.011.30120, 19.010.20091; Adobe Acrobat Reader 15.006.30475, 17.011.30120, 19.010.20091. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/acrobat/apsb19-07.html
- https://helpx.adobe.com/security/products/acrobat/apsb19-07.html
Get alerted when CVE-2019-7019 or the next vulnerability affects your stack