What’s Vulnerable › Vulnerabilities
CVE-2019-7131
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-01-28 · updated 2026-06-17
- Weakness: CWE-843
Description
Adobe Acrobat and Reader versions 2019.010.20064 and earlier, 2019.010.20064 and earlier, 2017.011.30110 and earlier version, and 2015.006.30461 and earlier have a type confusion vulnerability. Successful exploitation could lead to arbitrary code execution.
Affected products
- Adobe Acrobat DC: from 15.006.30060 before 15.006.30464; from 15.008.20082 before 19.010.20069; from 17.011.30059 before 17.011.30113 — fixed in 15.006.30464, 17.011.30113, 19.010.20069
- Adobe Acrobat Reader: from 15.006.30060 before 15.006.30464; from 15.008.20082 before 19.010.20069; from 17.011.30059 before 17.011.30113 — fixed in 15.006.30464, 17.011.30113, 19.010.20069
How to fix
Upgrade to a fixed version: Adobe Acrobat DC 15.006.30464, 17.011.30113, 19.010.20069; Adobe Acrobat Reader 15.006.30464, 17.011.30113, 19.010.20069. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/acrobat/apsb19-02.html
- https://helpx.adobe.com/security/products/acrobat/apsb19-02.html
Get alerted when CVE-2019-7131 or the next vulnerability affects your stack