What’s Vulnerable › Vulnerabilities
CVE-2019-7139
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 22.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-04-10 · updated 2026-06-17
- Weakness: CWE-89
Description
An unauthenticated user can execute SQL statements that allow arbitrary read access to the underlying database, which causes sensitive data leakage. This issue is fixed in Magento 2.1 prior to 2.1.18, Magento 2.2 prior to 2.2.9, Magento 2.3 prior to 2.3.2.
Affected products
- Adobe Magento Commerce: before 1.9.4.1; from 1.14.0.0 before 1.14.4.1; from 2.1.0 before 2.1.17; from 2.2.0 before 2.2.8; from 2.3.0 before 2.3.1 — fixed in 1.14.4.1, 1.9.4.1, 2.1.17, 2.2.8, 2.3.1
How to fix
Upgrade to a fixed version: Adobe Magento Commerce 1.14.4.1, 1.9.4.1, 2.1.17, 2.2.8. Check the vendor advisory for mitigations.
References
- https://magento.com/security/patches/magento-2.3.2-2.2.9-and-2.1.18-security-update-13
- https://www.ambionics.io/blog/magento-sqli
- https://magento.com/security/patches/magento-2.3.2-2.2.9-and-2.1.18-security-update-13
- https://www.ambionics.io/blog/magento-sqli
Get alerted when CVE-2019-7139 or the next vulnerability affects your stack