What’s Vulnerable › Vulnerabilities
CVE-2019-7198: Command Injection Vulnerability in QTS and QuTS hero
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-12-10 · updated 2026-06-17
- Weakness: CWE-77
Description
This command injection vulnerability allows attackers to execute arbitrary commands in a compromised application. QNAP have already fixed this vulnerability in the following versions of QTS and QuTS hero. QuTS hero h4.5.1.1472 build 20201031 and later QTS 4.5.1.1456 build 20201015 and later QTS 4.4.3.1354 build 20200702 and later
Affected products
- QNAP QTS: before 4.4.3.1354; before 4.5.1.1456 — fixed in 4.4.3.1354, 4.5.1.1456
- QNAP Systems Inc. QuTS hero: before h4.5.1.1472 — fixed in h4.5.1.1472
How to fix
Upgrade to a fixed version: QNAP QTS 4.4.3.1354, 4.5.1.1456; QNAP Systems Inc. QuTS hero h4.5.1.1472. Check the vendor advisory for mitigations.
References
- https://www.qnap.com/en/security-advisory/qsa-20-16
- https://www.qnap.com/en/security-advisory/qsa-20-16
Get alerted when CVE-2019-7198 or the next vulnerability affects your stack