What’s Vulnerable › Vulnerabilities
CVE-2019-7214
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 84.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-04-24 · updated 2026-06-17
- Weakness: CWE-502
Description
SmarterTools SmarterMail 16.x before build 6985 allows deserialization of untrusted data. An unauthenticated attacker could run commands on the server when port 17001 was remotely accessible. This port is not accessible remotely by default after applying the Build 6985 patch.
Affected products
- SmarterTools SmarterMail: from 16.0.6345 before 16.3.6985 — fixed in 16.3.6985
How to fix
Upgrade to a fixed version: SmarterTools SmarterMail 16.3.6985. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/160416/SmarterMail-6985-Remote-Code-Execution.html
- http://packetstormsecurity.com/files/173388/SmarterTools-SmarterMail-Remote-Code-Execution.html
- https://www.nccgroup.trust/uk/our-research/technical-advisory-multiple-vulnerabilities-in-smartermail/
- https://www.smartertools.com/smartermail/release-notes/current
- http://packetstormsecurity.com/files/160416/SmarterMail-6985-Remote-Code-Execution.html
- http://packetstormsecurity.com/files/173388/SmarterTools-SmarterMail-Remote-Code-Execution.html
- https://www.nccgroup.trust/uk/our-research/technical-advisory-multiple-vulnerabilities-in-smartermail/
- https://www.smartertools.com/smartermail/release-notes/current
Get alerted when CVE-2019-7214 or the next vulnerability affects your stack