What’s Vulnerable › Vulnerabilities
CVE-2019-7244
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-03-25 · updated 2026-06-17
- Weakness: CWE-665
Description
An issue was discovered in kerneld.sys in AIDA64 before 5.99. The vulnerable driver exposes a wrmsr instruction via IOCTL 0x80112084 and does not properly filter the Model Specific Register (MSR). Allowing arbitrary MSR writes can lead to Ring-0 code execution and escalation of privileges.
Affected products
- AIDA64 Extreme: before 5.99 — fixed in 5.99
How to fix
Upgrade to a fixed version: AIDA64 Extreme 5.99. Check the vendor advisory for mitigations.
References
- https://github.com/fireeye/Vulnerability-Disclosures/blob/master/FEYE-2019-0010/FEYE-2019-0010.md
- https://github.com/fireeye/Vulnerability-Disclosures/blob/master/FEYE-2019-0010/FEYE-2019-0010.md
Get alerted when CVE-2019-7244 or the next vulnerability affects your stack