What’s Vulnerable › Vulnerabilities
CVE-2019-7304: Local privilege escalation via snapd socket
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 60.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-04-23 · updated 2026-06-17
- Weakness: CWE-863
Description
Canonical snapd before version 2.37.1 incorrectly performed socket owner validation, allowing an attacker to run arbitrary commands as root. This issue affects: Canonical snapd versions prior to 2.37.1.
Affected products
- Canonical Ltd. snapd: before 2.37.1 — fixed in 2.37.1
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 18.10
How to fix
Upgrade to a fixed version: Canonical Ltd. snapd 2.37.1. Check the vendor advisory for mitigations.
References
- https://usn.ubuntu.com/3887-1/
- https://www.exploit-db.com/exploits/46361
- https://www.exploit-db.com/exploits/46362
- https://usn.ubuntu.com/3887-1/
- https://www.exploit-db.com/exploits/46361
- https://www.exploit-db.com/exploits/46362
Get alerted when CVE-2019-7304 or the next vulnerability affects your stack