What’s Vulnerable › Vulnerabilities
CVE-2019-7308
- Severity: medium (CVSS 5.6 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-02-01 · updated 2026-06-17
- Weakness: CWE-189
Description
kernel/bpf/verifier.c in the Linux kernel before 4.20.6 performs undesirable out-of-bounds speculation on pointer arithmetic in various cases, including cases of different branches with different state or limits to sanitize, leading to side-channel attacks.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 18.10
- Linux kernel: before 4.19.19; from 4.20.0 before 4.20.6 — fixed in 4.19.19, 4.20.6
- openSUSE Leap: 15.0
How to fix
Upgrade to a fixed version: Linux kernel 4.19.19, 4.20.6. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=979d63d50c0c0f7bc537bf821e056cc9fe5abd38
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=d3bd7413e0ca40b60cf60d4003246d067cafdeda
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00052.html
- http://www.securityfocus.com/bid/106827
- https://bugs.chromium.org/p/project-zero/issues/detail?id=1711
- https://cdn.kernel.org/pub/linux/kernel/v4.x/ChangeLog-4.20.6
- https://github.com/torvalds/linux/commit/979d63d50c0c0f7bc537bf821e056cc9fe5abd38
- https://github.com/torvalds/linux/commit/d3bd7413e0ca40b60cf60d4003246d067cafdeda
- https://support.f5.com/csp/article/K43030517
- https://support.f5.com/csp/article/K43030517?utm_source=f5support&%3Butm_medium=RSS
- https://usn.ubuntu.com/3930-1/
- https://usn.ubuntu.com/3930-2/
Get alerted when CVE-2019-7308 or the next vulnerability affects your stack