What’s Vulnerable › Vulnerabilities
CVE-2019-7323
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-02-04 · updated 2026-06-17
- Weakness: CWE-345
Description
GUP (generic update process) in LightySoft LogMX before 7.4.0 does not properly verify the authenticity of updates, which allows man-in-the-middle attackers to execute arbitrary code via a Trojan horse update. The update process relies on cleartext HTTP. The attacker could replace the LogMXUpdater.class file.
Affected products
- Logmx: before 7.4.0 — fixed in 7.4.0
How to fix
Upgrade to a fixed version: Logmx 7.4.0. Check the vendor advisory for mitigations.
References
- https://bmantra.github.io/logmx/logmx.html
- https://github.com/bmantra/bmantra.github.io/blob/master/logmx/logmx.html
- https://logmx.com/download
- https://bmantra.github.io/logmx/logmx.html
- https://github.com/bmantra/bmantra.github.io/blob/master/logmx/logmx.html
- https://logmx.com/download
Get alerted when CVE-2019-7323 or the next vulnerability affects your stack